If social network icons/logos are not appearing in your feed, or the posts are not loading properly in general (particularly Facebook), try viewing your feed using a different browser or using a different network connection for your device. 

If your internet connection has strong security measures in place (like a firewall), the icons may not load for you, but will for most other users. The surest way to check this is by trying a different internet connection to see if the problem persists. 

Ad-blocking software can also sometimes interfere with loading the icons. Try disabling the ad blocker on your page and within Juicer.io. 

In these situations, it's likely that most people who are viewing your feed are seeing the icons properly. You can adjust your local settings so that you see them properly, as well. 

If you see a question mark in place of a Facebook profile image, the most common cause is that a country or age restriction has been placed on the Facebook page, which will prevent our service from obtaining the image data. 

Please visit Facebook and check the settings of the Facebook page you are displaying within Juicer, and see whether any country or age restrictions have been enabled. If so, turning those off should allow Juicer to display the profile images.

If that doesn't seem to be the problem, double check that the Facebook account connected on your Connected Social Accounts page is an admin for the Facebook page you're displaying. Having an admin connected there helps us better display posts in some cases. 

Did this answer your question?