If your Juicer feed is not loading on your website, first make sure that you have placed the correct embed code into the page. View the source code of your webpage to double check this (and make sure the Juicer code is appearing there at all). 

If you need to re-paste your Juicer embed code into the page, you can find it in the "Embed in your site" panel of the Juicer dashboard (along the left-hand toolbar). If you are using the Wordpress shortcode, make sure you have downloaded and installed the Wordpress plugin for Juicer.

If your feed is still not loading, view your javascript console and see if any errors are appearing. If there are, and they are related to Juicer, please let us know via our Intercom platform or [email protected] If they are coming from elsewhere, you may need to fix these errors before the Juicer feed is able to load.

Developing your website locally? 

If you are developing your site locally and testing it by opening the HTML page in your browser, Juicer probably will not load. There are two ways around this. One is to run your site on a local server (something like this). Another is to change your embed code from:

<script src="//assets.juicer.io/embed.js" type="text/javascript"></script><link href="//assets.juicer.io/embed.css" media="all" rel="stylesheet" type="text/css" /><ul class="juicer-feed" data-feed-id="YOUR_FEED_NAME"><h1 class="referral"><a href="http://www.juicer.io">Powered by Juicer</a></h1></ul>

to:

<script src="http://assets.juicer.io/embed.js" type="text/javascript"></script><link href="http://assets.juicer.io/embed.css" media="all" rel="stylesheet" type="text/css" /><ul class="juicer-feed" data-feed-id="YOUR_FEED_NAME"><h1 class="referral"><a href="http://www.juicer.io">Powered by Juicer</a></h1></ul>

However, if your site is HTTPS (SSL), you may run into issues when you deploy in this way. 

Have a single page app? 

If you have a single page app (meaning you don't have a full-page refresh between each page), it's possible that the jQuery hook, document.ready that Juicer attaches to isn't firing. If you are capable, switch the Javascript line in your embed:

<script src="//assets.juicer.io/embed.js" type="text/javascript"></script>

to:

<script src="//assets.juicer.io/embed-amd.js" type="text/javascript"></script>

And then manually call Juicer.initialize() when you want your feed to be visible. When you navigate away, call Juicer.remove().

To see a more in depth example of this, please read our blog post on the subject.

None of the above helping? 

If nothing else is working, try loading your feed in an <iframe>. You can get the iframe version of your feed code from the "Embed in your site" area of the Juicer dashboard.

Did this answer your question?